2009/Session Audio Recordings

From Open Source Bridge Wiki
Jump to: navigation, search

Status

The Open Source Bridge 2009 sessions had their audio recorded, but isn't easy to listen to because it hasn't been processed yet. We need your help. The files need to be trimmed at the beginning and end, have pops removed, and have the audio levels normalized. It's not possible to simply run a program on the files to do this, a human being needs to run a program like Audacity to fix them up.

Data

  1. Original recordings: download all files as torrent or download individual files.
  2. znmeb1 renames and tags the files: download all files as torrent or individual download individual files. These were produced using these scripts. These are the best files to use as a starting point.


Volunteer

If you're interested in processing files, please write down the ones you've completed below, with your name (so you get credit!), the room, day, and session name.

Wednesday June 17 2009

St. Johns

Fremont

Steel

Thursday June 18 2009

St. Johns

Fremont

Broadway

Processing instructions

These instructions describe how to process an audio file using Audacity. You're expected to read the "Audacity usage" section to understand what these mean:

  1. Start Audacity
  2. Open the file (press CTRL-O or use menu File > Open)
  3. Listen to the beginning to identify its contents (press Home then Space)
  4. Confirm that the filename matches the contents [TODO describe expectations]
  5. Confirm that the MP3 tags (title, artist, album, etc) match the contents (menu File > Open Metadata Editor) [TODO describe expectations]
  6. Convert file to mono (menu Tracks > Stereo Track to Mono)
  7. Trim the audio before the session starts and after it ends (zoom in, select the region, zero it and delete).
  8. Fade in the beginning (select a short region right before the audio starts, zero, and then fade in using menu Effect > Fade in).
  9. Fade out the ending (just like Fade in beginning, but using menu Effect > Fade out).
  10. Fix all the pops. View the entire waveform (CTRL-F) and look for the few sharp spikes that go all the way or close to the edges of the wave form. Zoom and play a pop to determine it's cause, if it's:
    1. Noise, delete it (select, zero and delete)
    2. Content, compress it down using the envelope tool (F2, explained in Audacity usage section)
  11. Level all audio: select entire waveform with CTRL-A, then menu Effect > Leveler with Heavy, -75dB. This will take a while.
  12. Trim long silences, find them and delete them: menu Analyze > Silence Finder with 26db, 1.0 second minimum duration, 0.1 second before will add labels to silent sections.
  13. Fix quiet sections: Look for quiet regions (those whose waveforms are short and close to the 0 amplitude in the graph), and play them. If:
    1. Someone's speaking and you need to boost the level. For minor adjustments, use the Envelope tool. For bigger adjustments either use the Leveler or Amplify effect. The Amplify can be very handy because it cleanly boosts audio to a particular level, e.g. select a region, zero it and apply "New Peak Amplitude" of -5.0db and you'll get a section that's peaking at 0.5 amplitude -- it'd be great if there was a way to visually tinker with this, but there doesn't seem to be.
    2. Silences, if there's nothing happening for a while, consider just selecting the region, zeroing and deleting it.
  14. Compress all audio: select entire waveform with CTRL-A, then menu Effect > Compressor with Threshold -20db, Ratio 10:1, Attack 0.1, Decay: 1.0, yes to "Normalize to 0db after compressing"
  15. Save the file as FLAC (menu File > Export..., "OK", "FLAC Files").
  16. Share file [TODO explain how to share once workspace is setup]

Audacity usage

The processing instructions will assume that you're using the open source Audacity audio editor, you can find its manual is online.

Common Audacity commands:

  1. SHIFT-CTRL-F: Fit waveform vertically, this helps you see the full height of the waveform in your editor.
  2. CTRL-F : Fit waveform horizontally, this displays the entire entire wave form on the screen.
  3. Select region and CTRL-E : Fit waveform region, this displays just the region you selected.
  4. CTRL-A : Select entire waveform.
  5. + : Zoom in the waveform
  6. - : Zoom out of the waveform
  7. z : Adjust selection to zero crossings, starting and stopping it at nearest silences so you can delete or modify it cleanly
  8. DELETE : Delete selected region, be sure to zero it first.
  9. SPACE : Play from the beginning of the selection to it's end.
  10. F1 : Selector tool, used for selecting a region. Choose it and then click-and-hold left mouse button to select a region.
  11. F2 : Envelope tool, used for altering sound level in a region. Choose it and click carefully at the horizontal point where you want to begin adjusting the sound and vertically where the light and dark gray of the background behind the waveform touch. Then click again at the end of the region you want to adjust. Then click at a point within and drag up and down to increase or decrease the region's volume. You can drag the envelope points around if you make a mistake.
  12. CTRL-R : Repeat last-used effect on the selected region.